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About This Book 

 

 

 
The Thinware vBackup Administrator’s Guide contains information about installing, configuring and 
managing a backup solution for small and medium businesses. 

Intended Audience 
This book is for anyone who wants to provide backup solutions using Thinware vBackup. The 
information in this book is for experienced VMware vSphere, Microsoft Windows and Linux system 
administrators who are familiar with virtualization technology and backup operations and best practices. 

Product and Documentation Feedback 
Thinware welcomes your suggestions for improving our products and documentation. If you have 
comments, please send your feedback to: feedback@thinware.net 

Technical Support Resources 
The following technical support resources are available to you. The latest version of this book and 
release notes for the current version of Thinware vBackup can be found on the Thinware website at: 
http://www.thinware.net/Products/ThinwarevBackup/vBackupDocumentation/tabid/213/Default.aspx  

Online and Telephone 
Support 

To use online support to submit technical support requests, go to: 
http://www.thinware.net/Support/ContactSupport/tabid/217/Default.aspx 
 

Online Knowledgebase To view additional documentation such as miscellaneous how-to’s, bug 
advisories and release notes go to: 
http://www.thinware.net/Support/KnowledgeBase/tabid/220/Default.aspx 
 

Thinware Community 
Forum 

To collaborate with other Thinware vBackup users, create a community 
discussion or to provide feedback in an open forum go to: 
http://www.thinware.net/Community/Forums/tabid/70/Default.aspx 
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Protecting Data with Thinware vBackup 1 
 

Data backup, restoration and disaster recovery are among the most critical functions and processes of 
computer systems management. Thinware vBackup provides multiple solutions to perform backup and 
recovery related tasks, each suitable for a specific environment. This short introduction will help you as 
you get started designing, implementing and managing a solution to protect the data in your 
environment. 

Data Protection Concepts 
The following concepts are essential to your understanding of backup processes: 

1. Application-consistent Backup: A backup taken from snapshot after successfully quiescing the 
operating system and applications on the system being backed up. 

2. Crash-consistent Backup: A backup taken from snapshot without first quiescing the operating 
system and applications on the system being backed up. This is equivalent to removing power from 
the system. Although all on-disk data is consistent, it may contain information that is only partially 
written. 

3. Differential Backup: Backs up only the data that has changed since the last full backup. 
4. File-based Backup: Backs up selected files and folders.  
5. Full Backup: Backs up all data. A full backup serves as the starting point for differential and 

incremental backups. 
6. Image-based Backup: Backs up the operating system and all associated files including the system 

state, all application data and configurations and all user data. 
7. Inconsistent Backup: A backup NOT taken from snapshot. Depending on the amount of time it takes 

to process, this type of backup often includes data saved at different times. 
8. Incremental Backup: Backs up only the data that has changed since the last backup (whether full or 

incremental). 
9. Quiescing: A process of flushing all outstanding write operations to bring running application data 

and on-disk data to a consistent state. 
10. Replication: Much like creating an image-based backup, replication is the process of duplicating a 

system and creating a live or stand-by replica of the system being duplicated. 

Best Practices for Data Protection 
The following best practices are not an exhaustive list, but will help you in your planning and in being 
prepared should a disaster occur: 
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1. Understand your backup storage requirements. For example, if you are backing up a virtual machine 
with a 100 GB virtual hard disk that has 20% free space and you want to retain two backups, you will 
need at least 160 GB dedicated to this virtual machine on your backup target, plus 80 GB free to run 
the backup process each time (new backups and replicas are created before expired ones are 
removed). 

2. Monitor notifications and logs regularly. You should routinely review job completion notifications to 
verify backup and replication jobs are completing successfully. You should also know when to expect 
notifications. For example, if you have a backup job that runs each night and one day you don’t 
receive the regular notification, this may indicate a problem with scheduling or some other type of 
failure on the backup server that will need to be looked into. 

3. Have a well documented recovery plan and test recovering from backup regularly. Backed up data is 
of no use if it can’t be restored. You should routinely test recovering from backup. This not only 
helps you to verify that a recovery will be successful, it also familiarizes you with the process and 
helps you to know the amount of time a recovery will take. 

4. Use multiple external or hot-swappable backup drives and rotate them on a regular basis. Establish 
a backup storage plan that includes the regular rotation of backup drives. Doing so will improve your 
disaster preparedness in the event that a failure occurs with one of your backup drives.  

5. Rotate backup drives between onsite and offsite storage locations. To help protect backups in case 
of disaster, you should store at least one set of full backups at a secure offsite location. Doing so will 
improve your disaster preparedness in the event that physical damage occurs to hardware onsite. 

How Thinware vBackup Can Help 
Thinware vBackup addresses many of the issues and pain-points encountered with traditional backup 
approaches. Thinware vBackup can help you: 

1. Eliminate the need for backup windows by moving to a snapshot-based backup approach. 
2. Simplify backup administration by removing the need to install backup agents in systems you need 

to protect. 
3. Reduce the load on your VMware ESX(i) host servers by moving backup operations to a  dedicated 

backup proxy. 
4. Backup virtual machines regardless of their power state. 
5. Reduce the time required to restore a failed system. With imaged-based backups and replicas there 

is no need to perform the time consuming tasks involved with reinstalling the operating system and 
reinstalling and patching applications before recovering backed up data.  
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Understanding Thinware vBackup 2 
 

Thinware vBackup creates backups of virtual machines and replicas of physical/powered-on machines 
without interruption to system availability, data access or the services they provide. Thinware vBackup 
manages backups and replicas, removing them automatically once expired. Thinware vBackup also 
supports compression and thin provisioning to reduce space requirements of storage systems housing 
backups and replicas. 

Thinware vBackup Overview 
Thinware vBackup supports integration with VMware vStorage APIs for Data Protection (VADP) and/or 
VMware Consolidated Backup (VCB) to backup virtual machines running on VMware vSphere and 
VMware Virtual Infrastructure. Thinware vBackup eliminates the need for having a backup agent 
installed in each virtual machine you want to protect. Thinware vBackup also works with VMware 
vCenter Server to enable backup of virtual machines even when they are moved between host servers 
using VMware vMotion or VMware Distributed Resource Scheduler (DRS). 

Virtual machine backups created by Thinware vBackup are platform independent and are supported by 
standard VMware products and utilities such as VMware vCenter Converter Standalone, VMware 
Workstation, VMware Player, VMware Virtual Disk Manager and VMware Disk Mount to perform 
restoration and recovery functions. 

Thinware vBackup includes (currently experimental) features which support integration with VMware 
vCenter Converter Standalone Server to create and manage replicas of physical/powered-on machines. 

Thinware vBackup can be installed on a physical machine or a virtual machine and serves as a 
centralized backup proxy to facilitate and manage automated backup and replication operations. A 
single Thinware vBackup server can be used to protect an unlimited number of virtual machines running 
in multiple VMware environments. 

Virtual machine backups can be stored on any internal or external hard disk or any storage system 
accessible to the Thinware vBackup Server. Backups can be stored with or without compression and 
there are two levels of compression available. 

Physical/powered-on machine replicas can be stored on any datastore or storage system accessible to 
the target host server. All replicas are created with thin-provisioned virtual hard disks. 

To ensure application consistency in backups and replicas, Thinware vBackup supports Microsoft 
Windows Volume Shadow Copy Service (VSS). This means that applications write to disk any data 
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currently in memory prior to backup or replica job processing so that a later restore will bring the 
application back to a consistent state. VSS support is provided by and requires VMware Tools (for virtual 
machines) or VMware Converter agent (for physical/powered-on machines), which runs in the guest 
operating system.  

Software Licensing 
Licensing for Thinware vBackup is per VMware ESXi host server. One license entitlement is required for 
each host server virtual machines will be backed up from or restored to. 

License entitlements for Thinware vBackup come in three editions: 

1. Standard Edition: Includes all of the basic features required to schedule and automate backup of 
VMware vSphere virtual machines, does not support backup of virtual machines with thick-
provisioned disks 

2. Advanced Edition: Adds advanced features such as: e-mail notification, compression, support for 
thick-provisioned disks and the ability to exclude one or more of a virtual machine’s disks as needed 
from backup 

3. Professional Edition: Full featured with advanced compression and the ability to integrate with 
VMware vCenter Server 

It is possible to configure licensing in Thinware vBackup to support any number, and any mixture, of the 
above license editions. For example, you could have 2 host servers licensed as Advanced Edition and 3 
host servers licensed with Professional Edition all protected using the same Thinware vBackup server. 

Backing Up Virtual Machines 
During the backup process Thinware vBackup creates a snapshot of the virtual machine. This snapshot 
can be quiescent (application consistent) or non-quiescent (crash consistent) depending upon your 
needs and the configuration of your environment. Data is backed up from the snapshot, not the running 
virtual machine. This is done to ensure that backup data is consistent and that backup operations do not 
interfere with live data or services provided by the virtual machine. 

Backup Process Workflow 
The following steps describe the backup process workflow used by Thinware vBackup: 

1. Contact management server to determine host server the virtual machine is currently assigned to 
(note: this step is skipped if VMware vCenter Server is not used)  

2. Command host server to create temporary snapshot of virtual machine 
3. Use host server to access virtual disks contained in snapshot and virtual machine configuration 

information 
4. Copy virtual disk data and configuration information to backup target on Thinware vBackup server 
5. Command host server to remove temporary snapshot of virtual machine (created in step 2) 
6. Remove expired backup(s) from target on Thinware vBackup server 
7. Send notification e-mail (note: this step is skipped if e-mail notification is not configured) 
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8. Create entry in backup job’s log file 

Available Backup Job Types 
The following backup job types are available and can be configured based on the requirements and 
configuration of your environment: 

1. Image-SSH: Creates image-based backups of virtual machines (recommended for environments 
running VMware vSphere 4.x and later, works with “free” and “paid” editions of VMware vSphere 
Hypervisor) 

 
Note 1: The use of this job type requires VMware Virtual Disk Development Kit to be installed on 
the Thinware vBackup server, see “Installing VMware Virtual Disk Development Kit” on page 13 
and “Configuring Thinware vBackup Settings” on page 15 for more information 
Note 2: The use of this job type also requires SSH service to be running on the host server 
 

2. Image-VADP: Creates image-based backups of virtual machines using VMware vStorage APIs for 
Data Protection (recommended for environments running VMware vSphere 4.x and later, only 
works with “paid” editions of VMware vSphere Hypervisor) 

 
Note: The use of this job type requires VMware Virtual Disk Development Kit to be installed on 
the Thinware vBackup server, see “Installing VMware Virtual Disk Development Kit” on page 13 
and “Configuring Thinware vBackup Settings” on page 15 for more information 
 

3. Image-VCB: Creates image-based backups of virtual machines using VMware Consolidated Backup 
(for use with environments running VMware ESX(i) 3.x or 4.x and Virtual Center 2.5 or vCenter 
Server 4.x) 

 
Note: The use of this job type requires VMware Consolidated Backup to be installed on the 
Thinware vBackup server, see “Installing VMware Consolidated Backup” on page 13 and 
“Configuring Thinware vBackup Settings” on page 15 for more information 

 
Installing and Configuring Thinware 
vBackup 3 
 

Follow these steps to install and configure Thinware vBackup in your environment: 
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1. Verify minimum software and hardware requirements 
2. Setup Thinware vBackup server and install required integration utilities 
3. Install Thinware vBackup and configure settings 
4. Add management and host servers and virtual machines to inventory 
5. Create, configure and schedule backup and/or replication jobs 

Verifying System Requirements  
Certain software and hardware requirements must be met and should be verified as early in the setup 
process as possible. The following requirements are specific to Thinware vBackup and may be in 
addition to requirements specific to Microsoft Windows operating system or the VMware integration 
utilities which will be installed on the Thinware vBackup server: 

VMware Environment 
One or more VMware ESX(i) host server(s) and (optional) VMware Virtual Center/VMware vCenter 
Server management server(s) 

Supported versions: 
• VMware ESX(i)– 3.5 and later 
• VMware Virtual Center – 2.5 
• VMware vCenter Server – 4.0 and later 

Note: Thinware vBackup version 4.0.3 relies on VMware Virtual Disk Development Kit (VDDK) to 
facilitate virtual disk download and conversion processes for backup operations. Due to 
unresolved interoperability issues between VMware VDDK and the new security hardened 
characteristics of VMware vSphere 6.5, Thinware vBackup version 4.0.3 does not support 
backup of virtual machines running on VMware vSphere 6.5. If you need support for VMware 
vSphere 6.5 please upgrade to Thinware vBackup version 5.0.0. 

Thinware vBackup Server 
Hardware (physical or virtual, physical recommended): 

• Minimum 2 GB RAM, 4 GB recommended 
• Minimum dual-core processor, quad-core recommended 
• Network adapter (NIC) 
• Internal, external or hot-swappable hard drive for backup storage, multiple external or hot-

swappable drives recommended 

To use vBackup in “san” transport mode, additional hardware requirements include: 

• Shared Fiber Channel or iSCSI SAN storage system 
• Properly configured connectivity between Thinware vBackup server and SAN via Fiber Channel 

or iSCSI HBA or dedicated NIC and iSCSI Software Initiator 
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Software: 

• Microsoft Windows Operating System 
Supported versions: 

• Microsoft Windows 7 Professional, Enterprise or Ultimate 
• Microsoft Windows 8/8.1 Professional or Enterprise 
• Microsoft Windows 10 Professional or Enterprise 
• Microsoft Windows Server 2008/2008 R2 Standard, Enterprise or 

Datacenter 
• Microsoft Windows Server 2012/2012 R2 Essentials, Standard or Datacenter 
• Microsoft Windows Server 2016 Essentials, Standard or Datacenter 

Note 1: Only 64-bit versions of the above operating systems are supported. 
Note 2: Microsoft Windows Server Core is not supported for running Thinware 
vBackup. 

• Integration Utilities 
• VMware Virtual Disk Development Kit 

Supported versions: 
• 5.1.4 – build 2248791 
• 5.5.4 – build 2454786 

Note 1: VMware Virtual Disk Development Kit 5.5.x is only available in ZIP 
format (vs. Windows installer as with previous versions) and requires 
manual Windows registry configuration to work properly, please see 
Thinware vBackup troubleshooting section on our website at: 
http://www.thinware.net/Products/ThinwarevBackup/vBackupDocumentati
on/tabid/213/Default.aspx) 
Note 2: VMware Virtual Disk Development Kit 5.5.x does not include the 
VMware Disk Mount utility. Because of this, it is recommended that you 
install both VMware Virtual Disk Development Kit 5.1.4 and VMware Virtual 
Disk Development Kit 5.5.4. See “Configuring Thinware vBackup Settings” on 
page 15 for more information on how to configure Thinware vBackup to use 
two different versions of VMware Virtual Disk Development Kit. 
Note 3: VMware Virtual Disk Development Kit version 6.0 contains several 
bugs and is not recommended for use at this time. VMware supports the 
use of VMware Virtual Disk Development Kit version 5.5.4 with VMware 
vSphere 6.0 and we recommend this as well. 

• VMware Consolidated Backup (optional, VMware ESX(i) 3.x or 4.x only) 
Supported versions: 

• 1.5 Update 2 – build 226297 
• VMware vCenter Converter Standalone 
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Supported versions: 
• 5.0.1 – build 875114 
• 6.0.0 – build 2716716 
• 6.2.0 – build 7348398 

Setting Up a Thinware vBackup Server 
The following sections describe how to install the required integration utilities and Thinware vBackup on 
the Thinware vBackup server: 

Installing Required Integration Utilities 
Depending on the types of backup and/or replication jobs to be used, certain integration utilities are 
required to be installed on the Thinware vBackup server. The following sections describe the different 
integration utilities supported by Thinware vBackup and how to install them: 

Installing VMware Virtual Disk Development Kit 
If using Image-SSH or Image-VADP backup jobs to backup virtual machines, or to enable to recovery of 
individual files and folders from backups, download and install VMware Virtual Disk Development Kit. 

1. Download VMware Virtual Disk Development Kit from VMware at: 
https://my.vmware.com/web/vmware/details?downloadGroup=VSP510-VDDK-514&productId=285 

2. Complete installation of VMware Virtual Disk Development Kit accepting all defaults 

Installing VMware Consolidated Backup 
If using Image-VCB backup jobs to backup virtual machines, download and install VMware Consolidated 
Backup. 

1. Download VMware Consolidated Backup from VMware at: 
https://my.vmware.com/web/vmware/details?downloadGroup=VCB15U2&productId=230&rPId=28
75 

2. Complete installation of VMware Consolidated Backup accepting all defaults 
3. When prompted to install “VMware System devices” device driver, click Install 

Installing VMware vCenter Converter Standalone 
To enable restoration of virtual machine backups created by Thinware vBackup, or if using Replica-
Hosted or Replica-Managed replication jobs to replicate physical machines, download and install 
VMware vCenter Converter Standalone. Please note that VMware vCenter Converter Standalone is a 
separate VMware product not to be confused with vCenter Converter plugin in VMware vCenter Server. 

1. Download VMware vCenter Converter Standalone from VMware at: 
https://my.vmware.com/web/vmware/info/slug/infrastructure_operations_management/vmware_
vcenter_converter_standalone/5_0 

2. When prompted to select “Setup Type”: 
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• If simply needing to enable restoration of virtual machine backups, select “Local 
installation” 

• If also using Replica-Hosted or Replica-Managed replication jobs for physical/powered-
on machines, select “Client-Server installation (advanced)” and for “Custom Setup” set 
“Converter agent” to “This feature will not be available.” 

3. Complete installation of VMware vCenter Converter Standalone accepting all other defaults 

Note: It is also possible to install the server installation of VMware vCenter Converter Standalone on 
another system for remote processing of replication jobs. If this alternate configuration is used, a local 
installation of VMware vCenter Converter Standalone is still required on the Thinware vBackup server to 
enable restoration of virtual machine backups using VMware vCenter Converter Standalone. 

Installing Thinware vBackup 
Download and install Thinware vBackup. 

1. Download Thinware vBackup from Thinware at: 
http://www.thinware.net/Products/ThinwarevBackup/vBackupEULAAcceptance/tabid/214/Default.
aspx 

2. Complete installation of Thinware vBackup accepting all defaults 

Upgrading Thinware vBackup from a Previous Version 
Complete the following steps to upgrade Thinware vBackup from a previous version: 

1. VERY IMPORTANT – Backup Thinware vBackup datastore BEFORE uninstalling current version 
• If current version  of Thinware vBackup is earlier than 0.2.5, browse to the Thinware 

vBackup application directory (default path: C:\Program Files\Thinware\vBackup) and 
copy vBackup.xls to another directory (such as C:\Temp) 

• If current version of Thinware vBackup is 0.2.5 or later, open Thinware vBackup Client 
(Windows Start menu > All Programs > Thinware > Thinware vBackup Client) and from 
the Tools menu choose “Backup Datastore…”. Save datastore backup to a directory 
other than the Thinware vBackup application directory (such as C:\Temp) 

2. Uninstall current installed version of Thinware vBackup 
3. Download new version of Thinware vBackup from Thinware at: 

http://www.thinware.net/Products/ThinwarevBackup/vBackupEULAAcceptance/tabid/214/Default.
aspx 

4. Complete installation of new version of Thinware vBackup accepting all defaults 

Open Thinware vBackup Client and import the datastore backed up in step 1 (from the Tools menu, 
choose “Import Datastore…”)  

Obtaining and Installing Your Software License for Thinware vBackup 
A valid software license is required to use Thinware vBackup. Please review this section for instructions 
on how to obtain and install your software license for Thinware vBackup. 
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1. If you have not already done so, download and install Thinware vBackup, see “Installing Thinware 
vBackup” on page 14 for instructions. 

2. Open Thinware vBackup Client (Windows Start menu > All Programs > Thinware > Thinware vBackup 
Client) and from the Tools menu choose “Configure Licensing”. 

3. Use your cursor to highlight the string of data in the Hardware ID field and copy this to the 
clipboard. Be careful to select the entire string (expected format is 8 groups of characters separated 
by dashes, e.g. E6C2-30C3-7B4B-5493-06B9-DE58-0160-C757, the Hardware ID is case sensitive). 

4. Depending your licensing needs, request or order your license from Thinware at: 
• 30-Day Trial License Requests: 

http://www.thinware.net/Products/ThinwarevBackup/Try/tabid/231/Default.aspx 
• Standard Edition License Requests: 

http://www.thinware.net/Products/ThinwarevBackup/StandardEditionLicenseRequest/tabi
d/234/Default.aspx 

• Advanced and Professional Edition Orders: 
http://www.thinware.net/Products/ThinwarevBackup/tabid/202/www.thinware.net/Produ
cts/ThinwarevBackup/Buy/tabid/235/Default.aspx 

5. Once your license request or order has been processed you will receive an e-mail with your license 
file attached. The license e-mail will come from sales@thinware.net and the license file attachment 
will be in ZIP format. 

6. Follow the instructions included in the license e-mail to install your license. 

Configuring Thinware vBackup Settings 
Integration utilities settings will need to be configured before Thinware vBackup can successfully 
execute backup and/or replication jobs. E-mail notification settings and client preferences are optional. 
To view or edit settings, open Thinware vBackup Client (Windows Start menu > All Programs > Thinware 
> Thinware vBackup Client) and from the Tools menu choose “Settings…”. 

Integration Utilities 
1. VMware Virtual Disk Development Kit: If used, path to directory or directories VMware Virtual Disk 

Development Kit utilities are installed 
• VMware Virtual Disk Manager Application Directory: Path to directory VMware Virtual Disk 

Manager is installed (default path for this utility in VMware Virtual Disk Development Kit 
5.1.4: C:\Program Files\VMware\VMware Virtual Disk Development Kit\bin) 

• Disable VMware Virtual Disk Manager Logging: Disable this setting if you need VMware 
Virtual Disk Manager to log all tasks and results during backup and restore operations, the 
log for VMware Virtual Disk Manager can grow quite rapidly, it is recommended to only 
disable this setting when troubleshooting issues 

• Use same application directory setting for VMware Disk Mount: Enable this setting if you 
will be using the same version of VMware Virtual Disk Development Kit for both VMware 
Virtual Disk Manager and VMware Disk Mount utilities 
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• VMware Disk Mount Application Directory: Path to directory VMware Virtual Disk Manager 
is installed (default path for this utility in VMware Virtual Disk Development Kit 5.1.4: 
C:\Program Files\VMware\VMware Virtual Disk Development Kit\bin) 

2. VMware Consolidated Backup Application Directory: If used, path to directory VMware 
Consolidated Backup is installed (default path: C:\Program Files\VMware\VMware Consolidated 
Backup) 

3. VMware vCenter Converter Server: If used, connection settings for VMware vCenter Converter 
server 

• Name: Name or IP address of Thinware vBackup server (or VMware vCenter Converter 
server if separate system is used for remote replication job processing, see “Installing 
VMware vCenter Converter Standalone” on page 13) 

• Username and Password: Credentials for user account with administrative privileges on 
Thinware vBackup server (or VMware vCenter Converter server if separate system is used 
for remote replication job processing, see “Installing VMware vCenter Converter 
Standalone” on page 13) 

E-mail Notification 
1. SMTP Server: If used, connection settings for SMTP server 

• Name: Name or IP address of SMTP server 
• Port: Port used for SMTP mail service (if other than 25) 
• Username and Password: If required, credentials for user account with privileges to send 

mail on SMTP server 
2. From Address: E-mail address used for Thinware vBackup e-mail notifications 
3. Notification Recipients: One or more e-mail addresses to send Thinware vBackup e-mail 

notifications to 

Client Preferences 
1. Auto Refresh Interval: Interval (in seconds) for automatic datastore refreshes. This allows changes 

to job status and backup and replica inventory to be displayed. Default value is 180 seconds. Set 
value to 0 (zero) to disable auto refresh. 

2. Expand all servers at startup: If checked, all management and host servers in inventory tree will be 
expanded when Thinware vBackup Client is opened. Default value is no (unchecked). 

3. Show elapsed time in long format: If checked all elapsed time values will be displayed in long date 
format (example long format: 32 minutes and 47 seconds, standard format: 00:32:47). Default value 
is no (unchecked). 

Adding Management and Host Servers and Virtual Machines to Inventory 
See “Managing Inventory of Protected Systems” on page 18 
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Creating, Configuring and Scheduling Backup Jobs 
See “Managing Virtual Machine Backup Jobs” on page 20 and “Scheduling Backup and Replication Jobs 
Using Windows Task Scheduler” on page 21  
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Using Thinware vBackup 4 
 

Thinware vBackup Client provides an interface for managing protected systems, backup and replication 
jobs and the backups and replicas created by Thinware vBackup. The following sections provide an 
overview of how to use Thinware vBackup Client to perform these tasks. 

Managing Inventory of Protected Systems 
One of the first steps you will need to complete when setting up Thinware vBackup is adding 
management and host servers and virtual machines to inventory. Complete the following steps to add 
new systems or change or remove existing systems: 

To add a new VMware vCenter management server: 

1. In Thinware vBackup Client, from the Inventory menu, choose “Add Management Server…” 
2. On the Add Management Server wizard, enter the name or IP address of the management server, 

ports used for VADP and/or VCB backup operations (if other than 902 and 443 respectively), 
credentials for the user account used to connect and click Next 

3. Review the management server summary and check “Validate connectivity” to verify information 
provided in step 1 of the wizard and to enable discovery of attached host servers and virtual 
machines. If “Validate connectivity” is not checked, discovery of host servers and virtual machines 
will be disabled. Depending on system resources available, validating connectivity and discovering 
attached host servers and virtual machines can take up to a minute or longer. Click Next 

4. Select discovered host servers to be added. For each host server selected you will be prompted to 
provide ports used for SSH, VADP and/or VCB backup operations (if other than 22, 902 and 443 
respectively) and credentials for the user account used to connect. Click Next 

5. Select discovered virtual machines to be added and click Next 
6. Additional options will be added in a future release of Thinware vBackup. Click Next 
7. Review the wizard summary and click Finish to add the management server 

Note: Adding discovered host servers does not allow for selecting a license to be assigned to the host 
server (as with the Add/Edit Host Server wizard). Once the management server and all discovered host 
servers are added you will need to edit each host server and assign the appropriate license. 

To edit properties of an existing management server: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the management server in the inventory tree on the left 
3. On the management server’s Summary tab, under the Commands section, click “Edit Properties” 
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4. On the Edit Management Server wizard, follow the steps as on the Add Management Server wizard 
5. Review the wizard summary and click Finish to save your changes 

To remove a management server: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the management server in the inventory tree on the left 
3. On the management server’s Summary tab, under the Commands section, click Remove 

To add a new VMware ESX(i) host server: 

1. In Thinware vBackup Client, from the Inventory menu, choose “Add Host Server…” 
2. On the Add Host Server wizard, enter the name or IP address of the host server, ports used for SSH, 

VADP and/or VCB backup operations (if other than 22, 902 and 443 respectively), credentials for the 
user account used to connect and click Next 

3. Review the host server summary and check “Validate connectivity” to verify information provided in 
step 1 of the wizard and to enable discovery of attached virtual machines. If “Validate connectivity” 
is not checked, discovery of virtual machines will be disabled. Depending on system resources 
available, validating connectivity and discovering attached virtual machines can take up to a minute 
or longer. Click Next 

4. Select discovered virtual machines to be added and click Next 
5. Additional options will be added in a future release of Thinware vBackup. Click Next 
6. Select the appropriate license to assign to the host server and click Next 
7. Review the wizard summary and click Finish to add the host server 

To edit properties of an existing host server: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the host server in the inventory tree on the left 
3. On the host server’s Summary tab, under the Commands section, click “Edit Properties” 
4. On the Edit Host Server wizard, follow the steps as on the Add Host Server wizard 
5. Review the wizard summary and click Finish to save your changes 

To remove a host server: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the host server in the inventory tree on the left 
3. On the host server’s Summary tab, under the Commands section, click Remove 

To add a new virtual machine: 

1. In Thinware vBackup Client, from the Inventory menu, choose “Add Virtual Machine…” 
2. On the Add Virtual Machine wizard, enter the name of the virtual machine, select the management 

or host server the virtual machine is attached to and click Next 
3. Review the virtual machine summary and click Next 
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4. Additional options will be added in a future release of Thinware vBackup. Click Next 
5. Review the wizard summary and click Finish to add the virtual machine 

Tip: New virtual machines can also be automatically discovered and added using the Edit Management 
Server and Edit Host Server wizards. 

To edit properties of an existing virtual machine: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Commands section, click “Edit Properties” 
4. On the Edit Virtual Machine wizard, follow the steps as on the Add Virtual Machine wizard 
5. Review the wizard summary and click Finish to save your changes 

To remove a virtual machine: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Commands section, click Remove 

Managing Virtual Machine Backup Jobs 
Backup jobs are used to define the settings used when creating virtual machine backups. Complete the 
following steps to add new virtual machine backup jobs or change or remove existing virtual machine 
backup jobs: 

To add a new virtual machine backup job: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the job will be added for in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Commands section, click “Add Job” 
4. On the Add Job wizard, enter a name for the job, select the type (see “Available Backup Job Types” 

on page 10 for more information on available virtual machine backup job types) and click Next 
5. Review the job summary and click Next 
6. Provide appropriate settings for the job and click Next 
7. Review the wizard summary and click Finish to add the Job 

Tip: You can copy and paste backup jobs between virtual machines or within the jobs list of a single 
virtual machine. This helps if you need the same or similar backup job configuration for multiple virtual 
machines, or if you need to configure a similar backup job for a single virtual machine. To copy a backup 
job’s configuration to the clipboard, right-click the backup job and click Copy. You can then paste the 
backup job configuration to the same virtual machine or to any other virtual machine. 

To edit an existing virtual machine backup job: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
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2. Select the virtual machine the job is for in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and 

choose “Edit Properties…” 
4. On the Edit Job wizard, follow the steps as on the Add Job wizard 
5. Review the wizard summary and click Finish to save your changes 

To execute a virtual machine backup job ad hoc: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the job is for in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and 

choose “Execute Now” 

To remove a virtual machine backup job: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the job is for in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be removed and 

choose “Remove” 

Scheduling Backup and Replication Jobs Using Windows Task 
Scheduler 

Complete the following steps to schedule backup and replication jobs using Windows Task Scheduler: 

Create local user account for executing Thinware vBackup jobs: 

1. Open Computer Management (from the Windows Start menu, right-click Computer and choose 
Manage) 

2. In Computer Management, expand Local Users and Groups and click Users 
3. From the Action menu, choose “New User…” 
4. Complete New User form as described below and click Create: 

• User name: vbackup 
• Description: Local account for executing Thinware vBackup jobs 
• Password never expires: Yes (checked) 

5. A blank New User form is displayed, click Close 
6. Select the vbackup user account and from the Action menu, choose Properties 
7. On the Member Of tab, remove the Users group, add Administrators group and click OK 

Create Windows Task(s) for executing vBackup jobs: 

1. Open Task Scheduler (Windows Start menu > All Programs > Accessories > System Tools > Task 
Scheduler) 

2. In Task Scheduler, click Task Scheduler Library 
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3. From the Action menu choose “Create Task…” 
4. On the Create Task form, complete the General tab as described below: 

• Enter a unique name for the task (e.g. vBackup-[Machine Name]-[Job Name]) 
• Set task to run under the user the vbackup user account created above 
• Set task to Run whether the user is logged in or not 
• Set task to Run with highest privileges 

5. On the Triggers tab, add an On a schedule-based trigger per your requirements 
6. On the Actions tab, add a Start a program-based action as described below: 

• Set Program/script to path of Thinware vBackup executable (e.g. “C:\Program 
Files\Thinware\vBackup\vBackup.exe”) 

• Add arguments based on the following: 

 To execute the default job for a virtual machine: 

  -v [machine name] (e.g. -v vm01) 

 To execute a specific job for a virtual machine: 

  -v [machine name] -j [job name] (e.g. -v vm01 -j job01) 

 To execute the default job for a physical/powered-on machine: 

  -p [machine name] (e.g. -p server01) 

 To execute a specific job for a physical/powered-on machine: 

  -p [machine name] -j [job name] (e.g. -p server01 -j job01) 

7. Repeat step 2-6 as required to add additional jobs to be executed by this task 
8. Click OK to close the Create Task form 
9. Enter the password for the vbackup user account created above and click OK 

Note 1: The task will fail (without error) if you do not provide the job name argument (e.g. -j [job name]) 
and no default job is set for the virtual/physical machine. 
Note 2: Mapped drives (to a network share) in Windows do not persist to user sessions used to execute 
scheduled tasks. If you are using a mapped drive as your Backup Root you will need to map the drive in 
an action preceding the action that executes the Thinware vBackup job. An easy way to do this is using 
the Windows “net use” command (e.g. net use X: \\servername\sharename\foldername). 

Test task to verify proper configuration: 

1. In Task Scheduler, select the task created above 
2. From the Action menu, choose Run 

Note: Since the task is set to run whether the user is logged in or not it will run in the 
background and will not display the Thinware vBackup console 

3. Complete one or more of the following processes to verify successful completion 

For virtual machines: 
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1. Open VMware vSphere Client and review the task history for the host 
Note: There will be a “Create virtual machine snapshot” and a “Remove snapshot” task 
for the virtual machine each time a Thinware vBackup job is executed 

2. Review the log file for the job that was executed 
1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the job is for in the inventory tree on the left 
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job 

and choose “View Log” 
3. Verify virtual machine backup exists 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, verify status reads OK, right-click the backup 

and choose Open 

For physical/powered-on machines: 

1. Open VMware Converter Standalone Client and review the job and task history 
Note: The computer name/IP address in the Source column will match the 
physical/powered-on machine’s Name as displayed in Thinware vBackup Client. 

2. Open VMware vSphere Client and review the task history for the replica host 
Note: There will be a “Create virtual machine” and one or more “Find entity by UUID” 
and “Open remote disk for read/write” tasks each time a Thinware vBackup job is 
executed. 

3. Review the vBackup log file for the job that was executed 
1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the physical/powered-on machine the job is for in the inventory tree on the 

left 
3. On the physical/powered-on machine’s Summary tab, under the Jobs section, right-

click the job and choose “View Log” 
4. Verify physical/powered-on machine replica exists 

Note: Replicas are created and registered on the host server and datastore as specified 
in the job’s settings. Open VMware vSphere Client, connect to the host server and verify 
virtual machine (physical/powered-on machine replica) exists and is configured 
properly. 

Managing Virtual Machine Backups Created by Thinware vBackup 
Virtual machine backups created by Thinware vBackup can be managed in Thinware vBackup Client. 
Complete the following steps to manage virtual machine backups: 

To set a virtual machine backup as unmanaged: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 

 
Thinware, Inc. 23 
 



Thinware vBackup Administrator’s Guide  
 

3. On the virtual machine’s Backups tab, right-click the backup and choose “Set as Unmanaged” 

To move a virtual machine backup: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, right-click the backup and choose “Move…” 
4. Select location for the backup to be moved to and click OK 

To permanently delete a virtual machine backup: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, right-click the backup and choose “Delete from Disk” 

Troubleshooting Backup and Replication Job Failures 
E-mail notifications, log files and console messages are all available to assist you in troubleshooting 
backup and replication job failures. 

When reviewing e-mail notifications and log files, you should look for lines preceded by a capital “E” or 
lowercase “e”. Lines preceded by a capital “E” indicate that a critical error was encountered. Critical 
errors will cause a backup job to fail. Lines preceded by a lowercase “e” indicate that a minor error was 
encountered. Minor errors will not cause a backup job to fail, but should be looked into as they may 
cause things like e-mail notifications to not be sent or temporary password files to not be encrypted 
properly. 

To view the log file for a backup or replication job: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual or physical/powered-on machine the job is for in the inventory tree on the left 
3. On the virtual or physical/powered-on machine’s Summary tab, under the Jobs section, right-click 

the job and choose “View Log” 

Tip: Most backup job errors happen while the virtual machine’s disk files are being downloaded. To 
assist with troubleshooting Thinware vBackup captures the responses returned by VMware Virtual Disk 
Manager. You can find this information in each log entry under the section titled “VMware Virtual Disk 
Manager response for Hard disk X” (where X equals the hard disk number). For common errors reported 
by VMware Virtual Disk Manager you will also see a corresponding “tip” on how to resolve the issue or 
how to perceive the error (if it is merely a warning). 

To view the console for a backup or replication job: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual or physical/powered-on machine the job is for in the inventory tree on the left 
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3. On the virtual or physical/powered-on machine’s Summary tab, under the Jobs section, right-click 
the job to be edited and choose “Execute Now” 

4. Select a debug breakpoint of either Before or After. This will cause the console window to remain 
open after the job has completed, allowing you to review messages and the processes executed. 

Note: If you enable debug mode while running a backup job and the backup job fails none of the data 
created by the backup job will be removed. This is meant to help with troubleshooting, but can result in 
large amounts of backup data being left on backup storage in an unmanaged state. 

Tip: If you enable debug mode while running a backup job the temporary files created during the backup 
process are not automatically removed. These files are often useful when troubleshooting certain 
errors. 
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Hopefully it will never happen, but when it comes time to recover a virtual machine backup, or 
individual files and folders contained in a virtual machine backup, you will need to be prepared. The 
following sections describe the processes and tools used to restore full virtual machines, or individual 
files and folders, from virtual machine backups created by Thinware vBackup. 

Restoring Virtual Machines Using Thinware vBackup Client 
Virtual machine backups created by Thinware vBackup can be restored using the Restore Backup wizard 
in Thinware vBackup Client. Complete the following steps to restore a virtual machine backup using 
Thinware vBackup Client: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, right-click the backup and choose “Restore…” 
4. On the Restore Backup Wizard, enter a name for the new virtual machine, select the host server and 

datastore to create it on and click Next 
5. Review the virtual machine summary and click Next 
6. Select appropriate options for the restoration process and click Next 
7. Review the wizard summary and click Restore to begin the restoration process 
8. Once the restoration process completes, review the process summary and click Close to close the 

Restore Backup wizard 
 

Note: The use of the Restore Backup wizard in Thinware vBackup Client requires the SSH service to be 
running on the host server. 

Restoring Virtual Machines Using VMware vCenter Converter 
Standalone 

Virtual machine backups created by Thinware vBackup are platform independent, meaning you don’t 
necessarily need to use Thinware vBackup Client to restore them. If you are more familiar or more 
comfortable with using VMware vCenter Converter Standalone, this works just as well as the Restore 
Backup wizard in Thinware vBackup Client. Complete the following steps to restore a virtual machine 
backup using VMware vCenter Converter Standalone: 

1. In VMware vCenter Converter Standalone, from the File menu choose New > “Convert machine…” 

26 Thinware, Inc. 
 



  
 

2. Select “Backup image or third-party virtual machine” for source type, select the VMX file (example: 
D:\Backup\vlab5vm01\130120_040644\vlab5vm01.vmx) in the virtual machine backup’s folder for 
Virtual machine file and click Next 

3. Select “VMware Infrastructure virtual machine” for destination type, enter connection information 
for VMware Infrastructure server and click Next 

4. Enter a name for the new virtual machine and click Next 
5. Select the datastore, host and virtual machine version and click Next 
6. Set parameters for the conversion task as needed and click Next 
7. Review the conversion summary and click Finish to begin the restoration process 

Instantly Restoring Virtual Machines Using VMware Workstation or 
VMware Player 

Virtual machine backups created by Thinware vBackup are compatible with VMware Workstation and 
VMware Player products. Virtual machine backups can be launched in VMware Workstation or VMware 
Player for the purposes of testing or for instant restore when there is inadequate time available to 
complete a full restore to a VMware ESX(i) host server. Complete the following steps to instantly restore 
a virtual machine backup using VMware Workstation or VMware Player: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, right-click the backup and choose Open 
4. The backup’s file system folder will be opened in Windows Explorer, right-click the virtual machine 

configuration (VMX) file with the file name ending in _InstantRestore.vmx (example: 
vlab5vm01_InstantRestore.vmx) and click Open with > VMware Workstation (or VMware Player) 

 
Note 1: The instant restore version of the virtual machine is configured to have all network adapters 
disconnected at startup. 
Note 2: Virtual machine backups launched for testing or instant restore are protected from expiration 
and automatic deletion. To manually delete a virtual machine backup, simply right-click the backup and 
click “Delete from Disk”. 
Note 3: Virtual machine backups launched for testing or instant restore can be later powered-off and 
restored to a VMware ESX(i) host server (see “Restoring Virtual Machines Using Thinware vBackup 
Client” on page 26 or “Restoring Virtual Machines Using VMware vCenter Converter Standalone” on 
page 26 for instructions). 

Recovering Individual Files and Folders Using Thinware vBackup 
Client 

Virtual disks contained in virtual machine backups created by Thinware vBackup can be mounted as a 
separate drive in Windows to facilitate recovery of files and folders using the Mount Disks feature in 
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Thinware vBackup Client. Complete the following steps to mount a virtual machine backup’s virtual disk 
and recover individual files and folders using Thinware vBackup Client: 

1. In Thinware vBackup Client, from the View menu, choose Inventory 
2. Select the virtual machine the backup is for in the inventory tree on the left 
3. On the virtual machine’s Backups tab, right-click the backup and choose “Mount Disks…” 
4. On the Mount Disks form, select the disk you wish to mount and click “Mount…” 
5. On the Mount Disk form, enter the volume number you wish to mount, choose the drive letter to be 

used and click OK 
6. You will be directed back to the Mount Disks form and the volume and drive letter will be indicated 

next to all disks that are currently mounted 
7. When done, select the disk you wish to unmount and click Unmount or simply close the Mount Disks 

form to unmount all mounted disks 

Recovering Individual Files and Folders Using VMware Disk Mount 
Virtual disks contained in virtual machine backups created by Thinware vBackup are compatible with the 
VMware Disk Mount utility. VMware Disk Mount is installed with VMware Virtual Disk Development Kit 
and allows you to mount a virtual disk as a separate drive in Windows. Complete the following steps to 
mount a virtual machine backup’s virtual disk and recover individual files and folders using VMware Disk 
Mount: 

5. In Thinware vBackup Client, from the View menu, choose Inventory 
6. Select the virtual machine the backup is for in the inventory tree on the left 
7. On the virtual machine’s Backups tab, right-click the backup and choose Open 
8. Make a note of the virtual disk’s name that you wish to mount (example: vlab5vm01.vmdk) 
9. Open Command Prompt (Windows Start menu > All Programs > Accessories > Command Prompt) 
10. Mount the virtual disk as a drive by executing a command based on the following syntax: 

vmware-mount [next-available-drive-letter:] [path-to-virtual-disk] /m:n 

Example: C:\Program Files\VMware\VMware Virtual Disk Development Kit\bin\vmware-
mount.exe" X: D:\Backup\vlab5vm01\130120_040644\vlab5vm01.vmdk /m:n 

11. Open the drive mounted in step 6 and restore individual files and folders as needed 
12. When done, remove the mounted drive by executing a command based on the following syntax: 

vmware-mount [mounted-drive-letter:] /d 

Example: C:\Program Files\VMware\VMware Virtual Disk Development Kit\bin\vmware-
mount.exe" X: /d 
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