Thursday, September 28, 2023
Thinware Forums
ForumsForumsThinware vBacku...Thinware vBacku...DiscussionsDiscussions"Error while creating "Error while creating 'virtualmachine' file."
Previous Previous
Next Next
New Post
 7/23/2013 10:14 AM

I am getting the "Error while creating 'virtualmachine' file." error when attempting to backup virtual machines. To give you a better idea of what is going on, I'll explain what I've done so far.

I have two servers with identical hardware, each running ESXi 5.1.0-799733-standard. One is our production server and the other is our testing server.

To test vBackup, I erased everything on the testing server and did a reinstall of ESXi. I created two virtual machines on the testing server - one FreeBSD without VMWare tools installed and one Linux with VMWare tools installed. I installed vBackup on a Windows 7 virtual machine running on my desktop and after following the instructions in the vBackup Administrator's Guide, I was able to perform backups from the testing server with no problem.

I then installed vBackup on the PC we use for managing the production server. I followed the exact same instructions as when installing vBackup previously, but any time I try to run a backup (the backup types are always Backup-Image-SSH since I am running the free version of ESXi), it fails with this same error.

There are no spaces in the names of the virtual machines I am trying to backup or in the names of the jobs I create. I have also tried using the copy of vBackup that is installed on my desktop (which worked fine with the testing server), but I still get the exact same error message.

I have confirmed that SSH is enabled and working on the production server, and I can login to it with no problem using PuTTY on the same machines from which I'm running vBackup.

I've included a complete dump from the command executed by one of the backup jobs below. Thanks in advance for taking a look at this.

C:\Program Files\Thinware\vBackup>"C:\Program Files\Thinware\vBackup\vBackup.exe" -v EB -j backup -d after
Thinware(R) vBackup(R)
Version: (Version 0.3) - Expires: 9/30/2013
Copyright (c) 2009-2013 Thinware, Inc. All rights reserved.
Visit us at:

Process Started: 7/23/2013 10:19:23 AM

Application Settings:
- SMTP Server =
- SMTP Username =
- SMTP Password =
- SMTP From Address =
- Notification Recipients =
- VMware Virtual Disk Development Kit Install Path = C:\Program Files\VMware
\VMware Virtual Disk De
velopment Kit

Execution Arguments:
- Virtual Machine = EB
- Server =
- Server Username = root
- Server Password = *********
- Job = backup
- Job Type = Backup-Image-SSH
- Backup Root = C:\Users\user\Desktop\Backups
- Disk Exclusion = None
- Backups To Keep = 1
- Quiesce Guest File System = True
- Create Snapshot Task Timeout = 15
- Remove Snapshot Task Timeout = 15
- Encrypt Temporary Password File = False
- Compression Level = None
- Maximum Log Size = 10240
- Backup Type = Image-Full
- Debug = after

Validating settings...

SMTP server not provided, e-mail notification is disabled.

Attempting to ping server... Server responded to ping.

Establishing connection to server...

One or more certificate problems encountered while establishing connection

* A certification chain processed correctly, but terminated in a root cer
tificate which isn't trusted by the trust provider.
* The certificate's CN name does not match the passed value.

Server Platform: VMware ESXi 5.1.0 799733

Hypervisor property for updated.

Verifying virtual machine exists on server... Virtual machine located successful

Virtual Machine Guest OS: FreeBSD (32-bit)

GuestOS property for EB updated.

Backup Folder: C:\Users\user\Desktop\Backups\EB

Backup: 130723_101926

Log File: C:\Users\user\Desktop\Backups\EB\vBackup.log

Executing backup job...

Checking for existing temporary snapshot(s)... No temporary snapshots found.

Creating folder for backup data... Done.

Retrieving virtual machine ID... CRITICAL: Unable to retrieve virtual machine ID
. Error while creating 'virtualmachine' file. The filename, directory name, or v
olume label syntax is incorrect.

CRITICAL: Unable to complete backup.

Cleaning up after job failure... Done.

Process Complete: 7/23/2013 10:19:27 AM

Elapsed Time: 4 seconds

New Post
 7/24/2013 9:56 AM
Can you tell us the Windows version/edition on the PC you use to manage your production server (where vBackup is failing from)?

Thank you,

vBackup Team
New Post
 7/25/2013 8:19 AM

Yes. On that machine I am running Windows XP SP3 32-bit

New Post
 7/30/2013 8:08 PM

Same problem here ... same WXP SP3 32bit

Is there a problem with this?

New Post
 7/30/2013 8:13 PM

Same problem - Windows XP, 32 Bit

Previous Previous
Next Next
ForumsForumsThinware vBacku...Thinware vBacku...DiscussionsDiscussions"Error while creating "Error while creating 'virtualmachine' file."

Thinware Community
Membership Membership:
Latest New User Latest: decimagempt
New Today New Today: 0
New Yesterday New Yesterday: 1
User Count Overall: 41186

People Online People Online:
Visitors Visitors: 28
Members Members: 0
Total Total: 28

Privacy Statement  |  Terms Of Use
Copyright 2007-2019 Thinware, Inc.