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About This Book
The Thinware vBackup Administrator’s Guide contains information about installing, configuring and
managing a backup solution for virtualization environments running VMware vSphere.

Intended Audience
This book is for anyone who wants to provide backup solutions using Thinware vBackup. The
information in this book is for experienced VMware vSphere and Microsoft Windows system
administrators who are familiar with virtualization technology, backup operations and best practices.

Product and Documentation Feedback
Thinware welcomes your suggestions for improving our products and documentation. If you have
comments, please send your feedback to: feedback@thinware.net

Technical Support Resources
The following technical support resources are available to you. The latest version of this book and
release notes for the current version of Thinware vBackup can be found on the Thinware website at:
http://www.thinware.net/Products/ThinwarevBackup/vBackupDocumentation/tabid/213/Default.aspx
Online and Telephone
Support

To use online support to submit technical support requests, go to:
http://www.thinware.net/Support/ContactSupport/tabid/217/Default.aspx

Online Knowledgebase

To view additional documentation such as miscellaneous how-to’s, bug
advisories and release notes go to:
http://www.thinware.net/Support/KnowledgeBase/tabid/220/Default.aspx

Thinware Community
Forum

To collaborate with other Thinware vBackup users, create a community
discussion or to provide feedback in an open forum go to:
http://www.thinware.net/Community/Forums/tabid/70/Default.aspx

Thinware, Inc.
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Protecting Data with Thinware vBackup

1

Data backup, restoration and disaster recovery are among the most critical functions and processes of
computer systems management. Thinware vBackup provides multiple solutions to perform backup and
recovery related tasks, each suitable for a specific environment. This short introduction will help you as
you get started designing, implementing and managing a solution to protect the data in your
environment.

Data Protection Concepts and Definitions
The following concepts are essential to your understanding of backup processes:
1. Application-consistent Backup: A backup taken from snapshot after successfully quiescing the
operating system and applications on the system being backed up.
2. Crash-consistent Backup: A backup taken from snapshot without first quiescing the operating
system and applications on the system being backed up. This is equivalent to removing power from
the system. Although all on-disk data is consistent, it may contain information that is only partially
written.
3. Differential Backup: Backs up only the data that has changed since the last full backup.
4. File-based Backup: Backs up selected files and folders.
5. Full Backup: Backs up all data. A full backup serves as the starting point for differential and
incremental backups.
6. Host Server: A server running VMware vSphere Hypervisor (or VMware ESXi) that provides
computing resources to support one or more guest virtual machines.
7. Host Server Accessible Backup Repository: A storage location for backup data accessible to the host
server. With VMware vSphere this can be a VMFS datastore located on locally attached hard disks or
on a shared Fiber Channel or iSCSI SAN storage system or an NFS volume on a NAS storage system.
8. Image-based Backup: Backs up the operating system and all associated files including the system
state, all application data and configurations and all user data.
9. Inconsistent Backup: A backup NOT taken from snapshot. Depending on the amount of time it takes
to process, this type of backup often includes data saved at different times.
10. Incremental Backup: Backs up only the data that has changed since the last backup (whether full or
incremental).
11. Local Accessible Backup Repository: A storage location for backup data accessible to the backup
server.
12. Management Server: A server running VMware vCenter Server that provides a centralized interface
and processes for managing one or more host servers.
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13. Quiescing: A process of flushing all outstanding write operations to bring running application data
and on-disk data to a consistent state.
14. Replication: Much like creating an image-based backup, replication is the process of duplicating a
system and creating a live or stand-by replica of the system being duplicated.

Best Practices for Data Protection
The following best practices are not an exhaustive list, but will help you in your planning and in being
prepared should a disaster occur:
1. Understand your backup storage requirements. For example, if you are backing up a virtual machine
with a 100 GB virtual hard disk that has 20% free space and you want to retain two backups, you will
need at least 160 GB dedicated to this virtual machine on your backup target, plus 80 GB free to run
the backup process each time (when new backups are set to be created before expired backups are
removed).
2. Monitor notifications and logs regularly. You should routinely review job completion notifications to
verify backup jobs are completing successfully. You should also know when to expect notifications.
For example, if you have a backup job that runs each night and one day you don’t receive the
regular notification, this may indicate a problem with scheduling or some other type of failure on
the backup server that will need to be looked into.
3. Have a well documented recovery plan and test recovering from backup regularly. Backed up data is
of no use if it can’t be restored. You should routinely test recovering from backup. This not only
helps you to verify that a recovery will be successful, it also familiarizes you with the process and
helps you to know the amount of time a recovery will take.
4. Use multiple external or hot-swappable backup drives and rotate them on a regular basis. Establish
a backup storage plan that includes the regular rotation of backup drives. Doing so will improve your
disaster preparedness in the event that a failure occurs with one of your backup drives.
5. Rotate backup drives between onsite and offsite storage locations, or, if possible, automate
replication of backup data to an offsite location. To help protect backups in case of disaster, you
should store at least one set of full backups at a secure offsite location. Doing so will improve your
disaster preparedness in the event that physical damage occurs to onsite hardware.
6. Secure and limit access to backup servers and backup data. Consider taking steps to prevent
unauthorized access to sensitive data as well as steps to prevent manipulation of backup data by a
malicious third-party.

How Thinware vBackup Can Help
Thinware vBackup addresses many of the issues and pain-points encountered with traditional backup
approaches. Thinware vBackup can help you:
1. Eliminate the need for backup windows by moving to a snapshot-based backup approach.
2. Simplify backup administration by removing the need to install backup agents in systems you need
to protect.
Thinware, Inc.
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3. Reduce the load on your VMware ESXi host servers by moving backup operations to a dedicated
backup server.
4. Backup virtual machines regardless of their power state.
5. Reduce the time required to restore a failed system. With imaged-based backups there is no need to
perform the time consuming tasks involved with reinstalling and patching the operating system and
then reinstalling and patching applications before recovering backup data.
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Understanding Thinware vBackup

2

Thinware vBackup creates backups of virtual machines without interruption to system availability, data
access or the services they provide. Thinware vBackup manages backups, removing them automatically
once expired. Thinware vBackup also supports compression and thin-provisioning to reduce space
requirements of storage systems housing backups and replicas.

Thinware vBackup Overview
Thinware vBackup supports integration with VMware vSphere APIs for Data Protection (VADP) to
backup virtual machines running on VMware vSphere. Thinware vBackup eliminates the need for having
a backup agent installed in each virtual machine you want to protect. Thinware vBackup also works with
VMware vCenter Server to enable backup of virtual machines even when they are moved between host
servers using VMware vMotion or VMware Distributed Resource Scheduler (DRS).
Virtual machine backups created by Thinware vBackup are stored in native VMware format and are
supported by standard VMware products and utilities such as VMware vCenter Converter Standalone,
VMware Workstation, VMware Player, VMware Virtual Disk Manager and VMware Disk Mount to
perform restoration and recovery functions.
Thinware vBackup can be installed on a physical machine or a virtual machine and serves as a
centralized backup server to facilitate and manage automated backup operations. A single Thinware
vBackup server can be used to protect an unlimited number of virtual machines running in multiple
VMware environments.
Virtual machine backups can be stored on any storage system accessible to the VMware ESXi host server
the virtual machine is running on or any storage system accessible to the Thinware vBackup server.
Backups can be stored with or without compression and there are two levels of compression available.
To ensure application consistency in backups, Thinware vBackup supports quiescing a virtual machine’s
guest operating system by means of VMware Tools and, in the case of virtual machines running
Microsoft Windows, Microsoft Windows Volume Shadow Copy Service (VSS). This means that
applications will write to disk any data currently in memory prior to backup job processing so that a later
restore will bring the application back to a consistent state.

Software Licensing
Licensing for Thinware vBackup is per VMware ESXi host server. One license entitlement is required for
each host server virtual machines will be backed up from.
Thinware, Inc.
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License entitlements for Thinware vBackup come in three editions:
1. Standard Edition: Includes all of the basic features required to schedule and automate backup of
VMware vSphere virtual machines to local accessible storage
2. Advanced Edition: Adds advanced features such as: e-mail notification, compression, multiple
backup jobs per virtual machine, support for backing up to host server accessible storage and the
ability to exclude one or more of a virtual machine’s disks from backup
3. Professional Edition: Full featured with advanced compression and the ability to integrate with
VMware VADP and VMware vCenter Server
It is possible to configure licensing in Thinware vBackup to support any number, and any mixture, of the
above license editions. For example, you could have 2 host servers licensed as Advanced Edition and 3
host servers licensed with Professional Edition all protected using the same Thinware vBackup server.

Backing Up Virtual Machines
During the backup process Thinware vBackup creates a snapshot of the virtual machine. This snapshot
can be quiescent (application consistent) or non-quiescent (crash consistent) depending upon your
needs and the configuration of your environment. Data is backed up from the snapshot, not the running
virtual machine. This is done to ensure that backup data is consistent and that backup operations do not
interfere with live data or services provided by the virtual machine.

Backup Process Workflow
The following steps describe the backup process workflow used by Thinware vBackup:
1. Contact management server to determine host server the virtual machine is currently assigned to
(note: this step is skipped if VMware vCenter Server is not used)
2. Command host server to create temporary snapshot of virtual machine
3. Use host server to access virtual disks contained in snapshot and virtual machine configuration
information
4. Copy virtual disk data and configuration information to backup target on Thinware vBackup server
5. Command host server to remove temporary snapshot of virtual machine (created in step 2)
6. Remove expired backup(s)
7. Send notification e-mail (note: this step is skipped if e-mail notification is not configured)
8. Add backup to inventory in Thinware vBackup and record process results in task entry

Available Command Protocols
The following command protocols are available and can be configured individually for each host server
based on the requirements and configuration of your environment:
1. SSH: Utilizes SSH to communicate backup operation commands (works with “free” and “paid”
editions of VMware vSphere Hypervisor)
Note: The use of this command protocol requires SSH service to be running on the host server
10
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2. VADP: Utilizes VMware VADP to communicate backup operation commands (only works with “paid”
editions of VMware vSphere Hypervisor)

Available Data Transfer Protocols
The following data transfer protocols are available and can be configured individually for each host
server based on the requirements and configuration of your environment:
1. HTTPS-NFC: Utilizes HTTPS and VMware Network File Copy (NFC) to transfer backup data
Note 1: The use of this data transfer protocol requires VMware Virtual Disk Development Kit to
be installed on the Thinware vBackup server, see “Installing VMware Virtual Disk Development
Kit” on page 14 and “Configuring Thinware vBackup Settings” on page 15 for more information
Note 2: This data transfer protocol is not supported with VMware ESXi 6.5 or VMware ESXi 6.7
2. SCP: Utilizes Secure Copy (SCP) to transfer backup data
Note: The use of this data transfer protocol requires SSH service to be running on the host
server
3. SCP+C: Utilizes Secure Copy (SCP) with compression to transfer backup data
Note: The use of this data transfer protocol requires SSH service to be running on the host
server

Thinware, Inc.
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Installing and Configuring Thinware
vBackup

3

Follow these steps to install and configure Thinware vBackup in your environment:
1.
2.
3.
4.
5.

Verify minimum software and hardware requirements
Setup Thinware vBackup server and install required integration utilities
Install Thinware vBackup and configure settings
Add management and host servers and virtual machines to inventory
Create, configure and schedule backup jobs

Verifying System Requirements
Certain software and hardware requirements must be met and should be verified as early in the setup
process as possible. The following requirements are specific to Thinware vBackup and may be in
addition to requirements specific to Microsoft Windows operating system or the VMware integration
utilities which will be installed on the Thinware vBackup server:

VMware Environment
One or more VMware ESXi host server(s) and (optional) VMware Virtual Center/VMware vCenter Server
management server(s)
Supported versions:
• VMware ESXi – 3.5 and later
• VMware Virtual Center – 2.5
• VMware vCenter Server – 4.0 and later

Thinware vBackup Server
Hardware (physical or virtual):
•
•
•
•

Minimum 2 GB RAM, 4 GB recommended
Minimum dual-core processor, quad-core recommended
Network adapter (NIC)
If using local accessible backup repositories: Internal, external or hot-swappable hard drive
for backup storage, multiple external or hot-swappable drives recommended

Software:
•

12

Microsoft Windows Operating System
Supported versions:
Thinware, Inc.

•
•
•
•
•
•

Microsoft Windows 7 Professional, Enterprise or Ultimate
Microsoft Windows 8/8.1 Professional or Enterprise
Microsoft Windows 10 Professional or Enterprise
Microsoft Windows Server 2008/2008 R2 Standard, Enterprise or
Datacenter
Microsoft Windows Server 2012/2012 R2 Essentials, Standard or Datacenter
Microsoft Windows Server 2016 Essentials, Standard or Datacenter

Note 1: Only 64-bit versions of the above operating systems are supported.
Note 2: Microsoft Windows Server Core is not supported for running Thinware
vBackup.
•

Integration Utilities
• VMware Virtual Disk Development Kit (VDDK)
Supported versions:
• 5.1.4 – build 2248791
• 5.5.4 – build 2454786
Note 1: There are many versions of VMware VDDK available for download
on VMware's website and VMware's versioning numbers for VMware VDDK
can make choosing the proper version a little confusing. Because of this it is
important to note that the version of VMware VDDK you need to download
and install is determined by the utility using it, NOT the version of VMware
vSphere you are running.
Note 2: VMware VDDK 5.5.x is only available in ZIP format (vs. Windows
installer as with previous versions) and, by itself, requires manual Windows
registry configuration to work properly. VMware VDDK 5.5.x also does not
include the VMware Disk Mount utility. To work around these issues, it is
recommended that you install both VMware VDDK 5.1.4 and VMware VDDK
5.5.4. See “Configuring Thinware vBackup Settings” on page 15 for more
information on how to configure Thinware vBackup to use two different
versions of VMware VDDK.

Setting Up a Thinware vBackup Server
The following sections describe how to install the required integration utilities and Thinware vBackup on
the Thinware vBackup server:

Installing Required Integration Utilities
Depending on the data transfer protocols, backup repository types, backup disk formats or compression
levels to be used, certain integration utilities are required to be installed on the Thinware vBackup
server. The following sections describe the different integration utilities supported by Thinware vBackup
and how to install them:
Thinware, Inc.
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Installing VMware Virtual Disk Development Kit
If you will be using HTTPS-NFC data transfer protocol, local accessible backup repositories with hosted
disk format split-disk format or compression, or to enable to recovery of individual files and folders from
backups, download and install VMware Virtual Disk Development Kit (VDDK).
1. Download VMware VDDK 5.1.4 from VMware at:
https://my.vmware.com/web/vmware/details?downloadGroup=VSP510-VDDK-514&productId=285
2. Complete installation of VMware VDDK 5.1.4 accepting all defaults
3. Download VMware VDDK 5.5.4 from VMware at:
https://my.vmware.com/web/vmware/details?downloadGroup=VDDK554&productId=353
4. Unzip VMware-vix-disklib-5.5.4-2454786.x86_64.zip (downloaded in step 3) to C:\Temp\VMwarevix-disklib-5.5.4-2454786.x86_64 and copy unzipped folder to: C:\Program Files\VMware

Installing Thinware vBackup
Download and install Thinware vBackup.
1. Download Thinware vBackup from Thinware at:
http://www.thinware.net/Products/ThinwarevBackup/vBackupEULAAcceptance/tabid/214/Default.
aspx
2. Complete installation of Thinware vBackup accepting all defaults

Upgrading Thinware vBackup from a Previous Version
Complete the following steps to upgrade Thinware vBackup from a previous version:
1. VERY IMPORTANT – Backup the Thinware vBackup database BEFORE uninstalling current version
Open Thinware vBackup Client (Windows Start menu > All Programs > Thinware vBackup >
Thinware vBackup Client) and from the Tools menu choose “Backup Database…”. Save database
backup to a directory other than the Thinware vBackup application directory (such as C:\Temp)
2. Uninstall current installed version of Thinware vBackup
3. Download new version of Thinware vBackup from Thinware at:
http://www.thinware.net/Products/ThinwarevBackup/vBackupEULAAcceptance/tabid/214/Def
ault.aspx
4. Complete installation of new version of Thinware vBackup accepting all defaults
5. Open Thinware vBackup Client and import the database backed up in step 1 (from the Tools menu,
choose “Import Database…”)

Obtaining and Installing Your Software License for Thinware vBackup
A valid software license is required to use Thinware vBackup. Please review this section for instructions
on how to obtain and install your software license for Thinware vBackup.
1. If you have not already done so, download and install Thinware vBackup, see “Installing Thinware
vBackup” on page 14 for instructions.
14
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2. Open Thinware vBackup Client (Windows Start menu > All Programs > Thinware vBackup > Thinware
vBackup Client) and from the Tools menu choose “Configure Licensing”.
3. Click the Copy button next to the Hardware ID field. The hardware ID is needed when entering
requests or orders for licensing on our website.
4. Depending your licensing needs, request or order your license from Thinware at:
• 30-Day Trial License Requests:
http://www.thinware.net/Products/ThinwarevBackup/Try/tabid/231/Default.aspx
• Standard Edition License Requests:
http://www.thinware.net/Products/ThinwarevBackup/StandardEditionLicenseRequest/tabi
d/234/Default.aspx
• Advanced and Professional Edition Orders:
http://www.thinware.net/Products/ThinwarevBackup/tabid/202/www.thinware.net/Produ
cts/ThinwarevBackup/Buy/tabid/235/Default.aspx
5. Once your license request or order has been processed you will receive an e-mail with your license
file attached. The license e-mail will come from sales@thinware.net and the license file attachment
will be in ZIP format.
6. Follow the instructions included in the license e-mail to install your license.
Note 1: Licenses for Thinware vBackup are assigned to a specific computer and activated based on a
hardware fingerprint. Certain hardware changes can cause the hardware fingerprint to change and
thus invalidating your license. If this happens simply submit a license reactivation request to
sales@thinware.net and include your license key and the new hardware ID displayed on the
“Configure Licensing” screen in Thinware vBackup Client (see step 2 above).
Note 2: If the Thinware vBackup server is a member of an Active Directory domain all interactive
and non-interactive user sessions must use a domain user account when using Thinware vBackup to
execute backup jobs. Failure to login using a domain user account may cause backup jobs to fail due
to licensing errors.
Note 3: Restore processes do not require license validation. If your license becomes invalidated for
any reason you can still perform restore operations as needed (even though licensing errors are
displayed when opening Thinware vBackup Client).

Configuring Thinware vBackup Settings
In certain cases integration utilities settings will need to be configured before Thinware vBackup can
successfully execute jobs. Logging, e-mail notification settings and client preferences are optional. To
view or edit settings, open Thinware vBackup Client (Windows Start menu > All Programs > Thinware
vBackup > Thinware vBackup Client) and from the Tools menu choose “Settings…”.

Integration Utilities
1. VMware Virtual Disk Development Kit: If used, path to directory or directories VMware Virtual Disk
Development Kit (VDDK) utilities are installed

Thinware, Inc.
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•

•

•

•

VMware Virtual Disk Manager Application Directory: Path to directory VMware Virtual Disk
Manager is installed (if instructions for “Installing VMware Virtual Disk Development Kit” on
page 14 were used set this field to: C:\Program Files\VMware\VMware-vix-disklib-5.5.42454786.x86_64\bin)
Disable VMware Virtual Disk Manager Logging: Disable this setting if you need VMware
Virtual Disk Manager to log all tasks and results during backup and restore operations, the
log for VMware Virtual Disk Manager can grow quite rapidly, it is recommended to only
disable this setting when troubleshooting issues
Use same application directory setting for VMware Disk Mount: Enable this setting if you
will be using the same version of VMware Virtual Disk Development Kit for both VMware
Virtual Disk Manager and VMware Disk Mount utilities
VMware Disk Mount Application Directory: Path to directory VMware Disk Mount is
installed (if instructions for “Installing VMware Virtual Disk Development Kit” on page 14
were used set this field to: C:\Program Files (x86)\VMware\VMware Virtual Disk
Development Kit)

Logging
1. Enable Windows Event Logging: Controls whether Windows Event Log will be used to log backup
processes (default value: enabled—checked)
2. Enable Task Logging: Controls whether task history in Thinware vBackup will be used to log backup
processes (default value: enabled—checked)
3. Keep last (number) tasks in history: Number of task entries to maintain (default value: 10,000)
4. Disable support data logging: Controls whether support data will be saved with task entries (default
value: enabled—unchecked)

E-mail Notification
1. Send e-mail notifications: Controls whether e-mail notifications will be sent when a backup job
completes based on the selected criteria:
• When a job fails: When checked an e-mail notification will be sent when a job fails
• When a job completes with error(s): When checked an e-mail notification will be sent when
a job completes with one or more errors
• When a job completes successfully: When checked an e-mail notification will be sent when
a job completes successfully
2. From Address: E-mail address used for Thinware vBackup e-mail notifications
3. Notification Recipients: One or more e-mail addresses to send Thinware vBackup e-mail
notifications to

SMTP Server
1. Hostname/IP: Hostname or IP address of SMTP server
2. Port: Port used for SMTP mail service (if other than 25)
3. Connection Type: Sets the type of connection to be used when connecting to the SMTP server
(choices: Non-encrypted or Encrypted: Explicit SSL)
16
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4. Username and Password: If required, credentials for user account with privileges to send mail on
SMTP server

Client Preferences
1. Expand all datacenters and servers at startup: If checked, all datacenters, management servers and
host servers in inventory tree will be expanded when Thinware vBackup Client is opened. Default
value is enabled (unchecked).
2. Show elapsed time in long format: If checked all elapsed time values will be displayed in long date
format (example long format: 32 minutes and 47 seconds, standard format: 00:32:47). Default value
is diabled (unchecked).
3. Auto Refresh Interval: Interval (in seconds) for automatic database refreshes. This allows changes to
job status and backup inventory and task entries to automatically be displayed. Default value is 180
seconds (3 minutes). Set value to 0 (zero) to disable auto refresh.
4. Tasks to Display in History: Number of entries to display in task history. Default value is 50.
5. Recent Tasks Timeout: Time (in seconds) to display completed task entries in recent tasks pane.
Default value is 900 seconds (15 minutes). Set value to 0 (zero) to disable recent tasks pane.

Adding Management and Host Servers and Virtual Machines to Inventory
See “Managing Inventory of Protected Systems” on page 18

Creating, Configuring and Scheduling Backup Jobs
See “Managing Backup Jobs” on page 20 and “Scheduling Backup Jobs Using Windows Task Scheduler”
on page 21

Thinware, Inc.
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Using Thinware vBackup

4

Thinware vBackup Client provides an interface for managing protected systems, backup jobs and the
backups created by Thinware vBackup. The following sections provide an overview of how to use
Thinware vBackup Client to perform these tasks.

Managing Inventory of Protected Systems
One of the first steps you will need to complete when setting up Thinware vBackup is adding
management and host servers and virtual machines to inventory. Complete the following steps to add
new systems or change or remove existing systems:
To add a new VMware vCenter Server management server:
1. In Thinware vBackup Client, from the Inventory menu, choose “Add Management Server…”
2. On the Add Management Server wizard, enter the hostname or IP address of the management
server, port used for web services connections (if other than 443), credentials for the user account
used to connect and check “Validate connectivity” to validate connectivity and to enable discovery
of attached host servers and virtual machines. If “Validate connectivity” is not checked, discovery of
host servers and virtual machines will be disabled. Depending on system resources, validating
connectivity and discovering attached host servers and virtual machines can take up to a minute or
longer. Click Next
3. Review the management server summary and click Next
4. Select discovered host servers to be added. For each host server selected you will be prompted to
provide required settings for the host server. Click Next
5. Select discovered virtual machines to be added and click Next
6. Review the wizard summary and click Finish to add the management server
To edit properties of an existing management server:
1.
2.
3.
4.
5.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the management server in the inventory tree on the left
On the management server’s Summary tab, under the Commands section, click “Edit Properties”
On the Edit Management Server wizard, follow the steps as on the Add Management Server wizard
Review the wizard summary and click Finish to save your changes

To remove a management server:
1. In Thinware vBackup Client, from the View menu, choose Inventory
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2. Select the management server in the inventory tree on the left
3. On the management server’s Summary tab, under the Commands section, click Remove
To add a new VMware ESXi host server:
1. In Thinware vBackup Client, from the Inventory menu, choose “Add Host Server…”
2. On the Add Host Server wizard, enter the hostname or IP address of the host server, port used for
web services connections (if other than 443), select management server (if applicable), credentials
for the user account used to connect and check “Validate connectivity” to validate connectivity and
to enable discovery of attached virtual machines. If “Validate connectivity” is not checked, discovery
of host servers and virtual machines will be disabled. Depending on system resources, validating
connectivity and discovering attached host servers and virtual machines can take up to a minute or
longer. Click Next
3. Review the host server summary and click Next
4. Select discovered virtual machines to be added and click Next
5. Select command protocol and data transfer protocol to be used, enter ports used for SSH and/or
NFC (if other than 22 and 902 respectively) and click Next
6. Select the appropriate license to assign to the host server and click Next
7. Review the wizard summary and click Finish to add the host server
To edit properties of an existing host server:
1.
2.
3.
4.
5.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the host server in the inventory tree on the left
On the host server’s Summary tab, under the Commands section, click “Edit Properties”
On the Edit Host Server wizard, follow the steps as on the Add Host Server wizard
Review the wizard summary and click Finish to save your changes

To remove a host server:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the host server in the inventory tree on the left
3. On the host server’s Summary tab, under the Commands section, click Remove
To add a new virtual machine:
1. In Thinware vBackup Client, from the Inventory menu, choose “Add Virtual Machine…”
2. On the Add Virtual Machine wizard, enter the name of the virtual machine, select the management
or host server the virtual machine is attached to and click Next
3. Review the virtual machine summary and click Next
4. Review the wizard summary and click Finish to add the virtual machine
Tip: New virtual machines can also be automatically discovered and added using the Edit Management
Server and Edit Host Server wizards.
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To edit properties of an existing virtual machine:
1.
2.
3.
4.
5.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine in the inventory tree on the left
On the virtual machine’s Summary tab, under the Commands section, click “Edit Properties”
On the Edit Virtual Machine wizard, follow the steps as on the Add Virtual Machine wizard
Review the wizard summary and click Finish to save your changes

To remove a virtual machine:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Commands section, click Remove

Managing Backup Jobs
Backup jobs are used to define the settings used when creating virtual machine backups. Complete the
following steps to add new virtual machine backup jobs or change or remove existing virtual machine
backup jobs:
To add a new backup job:
1.
2.
3.
4.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the job will be added for in the inventory tree on the left
On the virtual machine’s Summary tab, under the Commands section, click “Add Job”
On the Add Job wizard, enter a name for the job, provide appropriate settings for the job, clicking
Next to continue after each section of settings
5. Review the wizard summary and click Finish to add the Job

Tip: You can copy and paste backup jobs between virtual machines or within the jobs list of a single
virtual machine. This helps if you need the same or similar backup job configuration for multiple virtual
machines, or if you need to configure a similar backup job for a single virtual machine. To copy a backup
job’s configuration to the clipboard, right-click the backup job and click Copy. You can then paste the
backup job configuration to the same virtual machine or to any other virtual machine.
To edit an existing backup job:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and
choose “Edit Properties…”
4. On the Edit Job wizard, follow the steps as on the Add Job wizard
5. Review the wizard summary and click Finish to save your changes
To execute a backup job ad hoc:
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1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and
choose “Execute Now”
To execute a backup job in test mode:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
6. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and
choose “Execute Now (test mode)”
Note: Executing a backup job in test mode simply verifies all virtual machine and backup job settings and
tests connectivity to the management and/or host server the virtual machine is currently assigned to—
no backup data will be created. This can be helpful when needing to verify settings for new jobs or when
troubleshooting errors with existing jobs.
To remove a virtual machine backup job:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be removed and
choose “Remove”

Scheduling Backup Jobs Using Windows Task Scheduler
Complete the following steps to schedule backup and replication jobs using Windows Task Scheduler:
Create Windows Scheduled Task(s) for executing vBackup jobs:
1. Open Task Scheduler (Windows Start menu > All Programs > Accessories > System Tools > Task
Scheduler)
2. In Task Scheduler, under Task Scheduler (Local), expand Task Scheduler Library folder, expand
Thinware folder and click vBackup folder
3. From the Action menu choose “Create Task…”
4. On the Create Task form, complete the General tab as described below:
• Enter a unique name for the task (e.g. vBackup-[Machine Name]-[Job Name])
• Set task to run under a user account with appropriate permissions
• Set task to Run whether the user is logged in or not
• Set task to Run with highest privileges
5. On the Triggers tab, add an On a schedule-based trigger per your requirements
6. On the Actions tab, add a Start a program-based action as described below:
• Set Program/script to path of Thinware vBackup executable (e.g. “C:\Program Files
(x86)\Thinware\vBackup\vBackup.exe”)
Thinware, Inc.
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•

Add arguments based on the following:
To execute the default job for a virtual machine:
-v [virtual machine name] (e.g. -v vm01)
To execute a specific job for a virtual machine:
-v [virtual machine name] -j [job name] (e.g. -v vm01 -j job01)

7. Repeat step 2-6 as required to add additional jobs to be executed by this task
8. Click OK to close the Create Task form
9. Enter the password for the user account the task will be ran under and click OK
Note 1: The task will fail if you do not provide the job name argument (e.g. -j [job name]) when no
default job is set for the virtual machine.
Note 2: All arguments containing spaces must be enclosed in quotes. For example if your virtual
machine is named “domain controller 1” (and you wish to execute the default job) the arguments should
be entered as -v “domain controller 1”. It is same for job name arguments. For example if your virtual
machine is named “domain controller 1” and you wish to execute a job named “job 1” the arguments
should be entered as -v “domain controller 1” -j “job 1”.
Note 3: Mapped drives (to a network share) in Windows do not persist to user sessions used to execute
scheduled tasks. If you are using a mapped drive as your Backup Root you will need to map the drive in
an action preceding the action that executes the Thinware vBackup job. An easy way to do this is using
the Windows “net use” command (e.g. net use X: \\servername\sharename\foldername).
Note 4: If the Thinware vBackup server is a member of an Active Directory domain all non-interactive
user sessions (such as user sessions created by scheduled tasks) must use a domain user account when
using Thinware vBackup to execute backup jobs. Failure to set scheduled tasks to run under a domain
user account may cause backup jobs to fail due to licensing errors.
Test task to verify proper configuration:
1. In Task Scheduler, select the task created above
2. From the Action menu, choose Run
Note: Since scheduled tasks run in non-interactive user sessions all processes will run in the
background and the Thinware vBackup console will not be displayed (as when executing a
backup job from Thinware vBackup Client)
3. Complete one or more of the following processes to verify successful completion
1. Open VMware vSphere Client and review the task history for the host server
Note: There will be a “Create virtual machine snapshot” and a “Remove snapshot” task
for the virtual machine each time a Thinware vBackup job is executed
2. Review the task history in Thinware vBackup for the virtual machine and backup job that
was executed
1. In Thinware vBackup Client, from the View menu, choose Inventory
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2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job
and choose “View Task History”
3. Verify virtual machine backup exists
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the backup is for in the inventory tree on the left
3. On the virtual machine’s Backups tab, verify the backup exists (for backups on local
accessible backup repositories you can also verify that the status reads OK and you
can right-click the backup and choose Open)

Managing Virtual Machine Backups Created by Thinware vBackup
Virtual machine backups created by Thinware vBackup can be managed in Thinware vBackup Client.
Complete the following steps to manage virtual machine backups:
To set a virtual machine backup as unmanaged:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the backup is for in the inventory tree on the left
3. On the virtual machine’s Backups tab, right-click the backup and choose “Set as Unmanaged”
To move a virtual machine backup:
1.
2.
3.
4.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the backup is for in the inventory tree on the left
On the virtual machine’s Backups tab, right-click the backup and choose “Move…”
Select location for the backup to be moved to and click OK

To permanently delete a virtual machine backup:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the backup is for in the inventory tree on the left
3. On the virtual machine’s Backups tab, right-click the backup and choose “Delete from Disk”

Troubleshooting Backup Job Failures
E-mail notifications, task entries and console messages are all available to assist you in troubleshooting
backup job failures.
When reviewing e-mail notifications and task entries, you should look for minor errors (preceded by the
word “Error”) or critical errors (preceded by the word “CRITICAL”). Minor errors will typically not cause a
backup job to fail, but should be looked into as they may indicate other issues. Critical errors will always
cause a backup job to fail.
To view the task history for a backup job:

Thinware, Inc.

23

Thinware vBackup Administrator’s Guide

1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job and choose “View
Task History”
Tip: Most backup job errors happen while the virtual machine’s disk files are being backed up. To assist
with troubleshooting Thinware vBackup captures the response returned by the VMware utility/API
being used. If the backup job fails due to an error encountered while backing up a virtual machine’s disk
files you can find the error detail in the task entry. The error message will be preceded with “Unable to
verify backup of Hard disk X” (where X equals the hard disk number). For common errors you may also
see a corresponding “tip” on how to resolve the issue or how to perceive the error (if it is merely a
warning).
To execute a backup job in interactive mode (where the console output is displayed):
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and
choose “Execute Now”
To execute a backup job in test mode:
1. In Thinware vBackup Client, from the View menu, choose Inventory
2. Select the virtual machine the job is for in the inventory tree on the left
3. On the virtual machine’s Summary tab, under the Jobs section, right-click the job to be edited and
choose “Execute Now (test mode)”
Note: Executing a backup job in test mode simply verifies all virtual machine and backup job settings and
tests connectivity to the management and/or host server the virtual machine is currently assigned to—
no backup data will be created. This can be helpful when needing to verify settings for new jobs or when
troubleshooting errors with existing jobs.
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Data Restoration and Disaster Recovery

5

Hopefully it will never happen, but when it comes time to restore a virtual machine from backup, or to
recover individual files and folders contained in a virtual machine backup, you will need to be prepared.
The following sections describe the processes and tools that can be used to restore full virtual machines,
or to recover individual files and folders, from virtual machine backups created by Thinware vBackup.

Restoring Virtual Machine from Backup Located on Host Server
Accessible Backup Repository
Instantly Restoring Virtual Machine from Backup Using VMware vSphere Client or
VMware Host Client
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be instantly restored using VMware vSphere Client or VMware Host Client.
Complete the following steps to instantly restore a virtual machine from backup using VMware vSphere
Client or VMware Host Client:
1. Open VMware vSphere Client (desktop) or VMware Host Client (web) and login to the host server
2. Use the datastore browser to locate the backup you wish to restore
3. Right-click the virtual machine’s configuration (VMX) file in the backup directory and click “Register
VM” (note: in the desktop version of VMware vSphere Client this menu item reads “Add to
Inventory”)
4. Locate the virtual machine in inventory and power-on, the virtual machine will now be running from
backup storage
5. In Thinware vBackup Client, from the View menu, choose Inventory
6. Select the virtual machine the backup is for in the inventory tree on the left
7. On the virtual machine’s Backups tab, right-click the backup and click
“Remove from Inventory”
Note 1: To be compatible with instantly restoring using VMware vSphere Client the virtual machine
backup’s virtual disk file(s) must be saved in managed disk format.
Note 2: Virtual machine backups registered and powered-on for instant restore can be later powered-off
and restored to production storage (see “Restoring Virtual Machine from Backup Using VMware vSphere
Client” on page 26 or “Restoring Virtual Machine from Backup Using VMware ESXi Shell” on page 26 for
instructions).
Thinware, Inc.
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Restoring Virtual Machine from Backup Using VMware vSphere Client or VMware
Host Client
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be restored using VMware vSphere Client or VMware Host Client. Complete the
following steps to restore a virtual machine from backup using VMware vSphere Client or VMware Host
Client:
1. Open VMware vSphere Client (desktop) or VMware Host Client (web) and login to the host server
2. Use the datastore browser to locate the backup you wish to restore
3. Right-click the backup directory and click Move, select new location for virtual machine data folder
on production storage
4. Once the backup directory is moved to production storage, right-click the virtual machine’s
configuration (VMX) file (located in the new data folder location) and click “Register VM” (note: in
the desktop version of VMware vSphere Client this menu item reads “Add to Inventory”)
5. Locate the VM in inventory and power-on, the virtual machine will now be running from production
storage
6. In Thinware vBackup Client, from the View menu, choose Inventory
7. Select the virtual machine the backup is for in the inventory tree on the left
8. On the virtual machine’s Backups tab, right-click the backup and click
“Remove from Inventory”
Note 1: To be compatible with restoring using VMware vSphere Client the virtual machine backup’s
virtual disk file(s) must be saved in managed disk format.
Note 2: If the virtual machine backup was previously instantly restored, and is now running or registered
from backup storage, it must first be powered-off and removed inventory before completing these
steps.

Restoring Virtual Machine from Backup Using VMware ESXi Shell
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be restored using VMware ESXi Shell. Restoring virtual machines from backup
using VMware ESXi Shell provides more options than using VMware vSphere Client or VMware Host
Client, but may be more complicated for users without more advanced knowledge of VMware ESXi.
Complete the following steps to restore a virtual machine from backup using VMware ESXi Shell:
1. Access VMware ESXi Shell (local or remote) and login to the host server
2. Create directory for virtual machine data folder on production storage using mkdir command
Syntax: mkdir %directory-path%
Example: mkdir /vmfs/volumes/datastore1/vm01
3. Obtain list of virtual machine backup’s files using ls command, the list of file names will be used in
steps 4, 5 and 6
Syntax: ls %directory-path%
Example: ls /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001
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Note 1: Make a note of the .vmx, .nvram and .vmdk file names
Note 2: Ignore VMDK files ending with “-flat.vmdk” or “-s###.vmdk”, these files will not be used
Note 3: If the virtual machine backup was created before the virtual machine was powered-on
for the first time a non-volatile RAM (NVRAM) file may not exist in the backup directory
4. Copy virtual machine backup’s configuration (VMX) file to directory to directory created in step 2
using cp command
Syntax: cp %source-vmx-path% %destination-vmx-path%
Example: cp /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001/vm01.vmx
/vmfs/volumes/datastore1/vm01/vm01.vmx

5. Copy virtual machine backup’s non-volatile RAM (NVRAM) file to directory created in step 2 using cp
command
Syntax: cp %source-nvram-path% %destination-nvram-path%
Example: cp /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001/vm01.nvram
/vmfs/volumes/datastore1/vm01/vm01.nvram

Note: If the virtual machine backup was created before the virtual machine was powered-on for
the first time a non-volatile RAM (NVRAM) file may not exist in the backup directory
6. Copy virtual machine backup’s virtual disk (VMDK) file(s) to directory created in step 2 using
vmkfstools command
Syntax: vmkfstools –i %source-vmdk-path% %destination-vmdk-path% -d %disk-format%
Disk format options: thin, zeroedthick or eagerzeroedthick
Example: vmkfstools /vmfs/volumes/nas1-backup/vmbackup/vm01/180531_060001/vm01.vmdk /vmfs/volumes/datastore1/vm01/vm01.vmdk –d
zeroedthick

7.

8.

9.

10.

Note 1: Do not copy the VMDK files ending with “-flat.vmdk”, these files will be created in the
destination directory automatically
Note 2: Do not copy the VMDK files ending with “-s###.vmdk”, these files will not be used
If different source and destination file names were used in steps 4, 5 and 6 use vi command to edit
file name references in machine configuration (VMX) file created in step 4
Syntax: vi %vmx-path%
Example: vi /vmfs/volumes/datastore1/vm01/vm01.vmx
Note: When finished editing, press ESC, type :wq and press Enter
Register restored virtual machine using vim-cmd solo/registervm command and virtual machine
configuration (VMX) file created in step 4
Syntax: vim-cmd solo/registervm %vmx-path%
Example: vim-cmd solo/registervm /vmfs/volumes/datastore1/vm01/vm01.vmx
Obtain restored virtual machine’s VMID using vim-cmd vmsvc/getallvms command, the VMID will
be used to power-on the restored virtual machine in step 10
Syntax: vim-cmd vmsvc/getallvms
Note: The VMID is listed in the first column, make a note of this
Power-on restored virtual machine using vim-cmd vmsvc/power.on command and restored virtual
machine’s VMID obtained in step 9
Syntax: vim-cmd vmsvc/power.on %vmid%
Example: vim-cmd vmsvc/power.on 54
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Note 1: Restoring a virtual machine using VMware Shell requires ESXi Shell (for local shell) or SSH (for
remote shell) service to be running on the host server.
Note 2: If the virtual machine backup was previously instantly restored, and is now running or registered
from backup storage, it must first be powered-off and removed inventory before completing these
steps.

Restoring Virtual Machine from Backup Located on Local Accessible
Backup Repository
Instantly Restoring Virtual Machine from Backup Using VMware Workstation or
VMware Player
Virtual machine backups created by Thinware vBackup are compatible with VMware Workstation and
VMware Player products. Virtual machine backups can be launched in VMware Workstation or VMware
Player for the purposes of testing or for instant restore when there is inadequate time available to
complete a full restore to a VMware ESXi host server. Complete the following steps to instantly restore a
virtual machine backup using VMware Workstation or VMware Player:
1.
2.
3.
4.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the backup is for in the inventory tree on the left
On the virtual machine’s Backups tab, right-click the backup and click Open
The backup’s file system folder will be opened in Windows Explorer, right-click the virtual machine
configuration (VMX) file and click Open with > VMware Workstation (or VMware Player)

Note 1: To be compatible with instantly restoring using VMware Workstation or VMware Player the
virtual machine backup’s virtual disk file(s) must be saved in hosted disk format.
Note 2: Virtual machine backups launched for testing or instant restore are protected from expiration
and automatic deletion. To manually delete a virtual machine backup, simply right-click the backup and
click “Delete from Disk”.
Note 3: Virtual machine backups launched for testing or instant restore can be later powered-off and
restored to a VMware ESXi host server (see “Restoring Virtual Machine from Backup Located on Host
Server Accessible Backup Repository

Instantly Restoring Virtual Machine from Backup Using VMware vSphere Client or
VMware Host Client
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be instantly restored using VMware vSphere Client or VMware Host Client.
Complete the following steps to instantly restore a virtual machine from backup using VMware vSphere
Client or VMware Host Client:
8. Open VMware vSphere Client (desktop) or VMware Host Client (web) and login to the host server
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9. Use the datastore browser to locate the backup you wish to restore
10. Right-click the virtual machine’s configuration (VMX) file in the backup directory and click “Register
VM” (note: in the desktop version of VMware vSphere Client this menu item reads “Add to
Inventory”)
11. Locate the virtual machine in inventory and power-on, the virtual machine will now be running from
backup storage
12. In Thinware vBackup Client, from the View menu, choose Inventory
13. Select the virtual machine the backup is for in the inventory tree on the left
14. On the virtual machine’s Backups tab, right-click the backup and click
“Remove from Inventory”
Note 1: To be compatible with instantly restoring using VMware vSphere Client the virtual machine
backup’s virtual disk file(s) must be saved in managed disk format.
Note 2: Virtual machine backups registered and powered-on for instant restore can be later powered-off
and restored to production storage (see “Restoring Virtual Machine from Backup Using VMware vSphere
Client” on page 26 or “Restoring Virtual Machine from Backup Using VMware ESXi Shell” on page 26 for
instructions).

Restoring Virtual Machine from Backup Using VMware vSphere Client or VMware
Host Client
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be restored using VMware vSphere Client or VMware Host Client. Complete the
following steps to restore a virtual machine from backup using VMware vSphere Client or VMware Host
Client:
9. Open VMware vSphere Client (desktop) or VMware Host Client (web) and login to the host server
10. Use the datastore browser to locate the backup you wish to restore
11. Right-click the backup directory and click Move, select new location for virtual machine data folder
on production storage
12. Once the backup directory is moved to production storage, right-click the virtual machine’s
configuration (VMX) file (located in the new data folder location) and click “Register VM” (note: in
the desktop version of VMware vSphere Client this menu item reads “Add to Inventory”)
13. Locate the VM in inventory and power-on, the virtual machine will now be running from production
storage
14. In Thinware vBackup Client, from the View menu, choose Inventory
15. Select the virtual machine the backup is for in the inventory tree on the left
16. On the virtual machine’s Backups tab, right-click the backup and click
“Remove from Inventory”
Note 1: To be compatible with restoring using VMware vSphere Client the virtual machine backup’s
virtual disk file(s) must be saved in managed disk format.
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Note 2: If the virtual machine backup was previously instantly restored, and is now running or registered
from backup storage, it must first be powered-off and removed inventory before completing these
steps.

Restoring Virtual Machine from Backup Using VMware ESXi Shell
When located on host server accessible backup repositories virtual machine backups created by
Thinware vBackup can be restored using VMware ESXi Shell. Restoring virtual machines from backup
using VMware ESXi Shell provides more options than using VMware vSphere Client or VMware Host
Client, but may be more complicated for users without more advanced knowledge of VMware ESXi.
Complete the following steps to restore a virtual machine from backup using VMware ESXi Shell:
11. Access VMware ESXi Shell (local or remote) and login to the host server
12. Create directory for virtual machine data folder on production storage using mkdir command
Syntax: mkdir %directory-path%
Example: mkdir /vmfs/volumes/datastore1/vm01
13. Obtain list of virtual machine backup’s files using ls command, the list of file names will be used in
steps 4, 5 and 6
Syntax: ls %directory-path%
Example: ls /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001
Note 1: Make a note of the .vmx, .nvram and .vmdk file names
Note 2: Ignore VMDK files ending with “-flat.vmdk” or “-s###.vmdk”, these files will not be used
Note 3: If the virtual machine backup was created before the virtual machine was powered-on
for the first time a non-volatile RAM (NVRAM) file may not exist in the backup directory
14. Copy virtual machine backup’s configuration (VMX) file to directory to directory created in step 2
using cp command
Syntax: cp %source-vmx-path% %destination-vmx-path%
Example: cp /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001/vm01.vmx
/vmfs/volumes/datastore1/vm01/vm01.vmx

15. Copy virtual machine backup’s non-volatile RAM (NVRAM) file to directory created in step 2 using cp
command
Syntax: cp %source-nvram-path% %destination-nvram-path%
Example: cp /vmfs/volumes/nas1-backup/vm-backup/vm01/180531_060001/vm01.nvram
/vmfs/volumes/datastore1/vm01/vm01.nvram

Note: If the virtual machine backup was created before the virtual machine was powered-on for
the first time a non-volatile RAM (NVRAM) file may not exist in the backup directory
16. Copy virtual machine backup’s virtual disk (VMDK) file(s) to directory created in step 2 using
vmkfstools command
Syntax: vmkfstools –i %source-vmdk-path% %destination-vmdk-path% -d %disk-format%
Disk format options: thin, zeroedthick or eagerzeroedthick
Example: vmkfstools /vmfs/volumes/nas1-backup/vmbackup/vm01/180531_060001/vm01.vmdk /vmfs/volumes/datastore1/vm01/vm01.vmdk –d
zeroedthick
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17.

18.

19.

20.

Note 1: Do not copy the VMDK files ending with “-flat.vmdk”, these files will be created in the
destination directory automatically
Note 2: Do not copy the VMDK files ending with “-s###.vmdk”, these files will not be used
If different source and destination file names were used in steps 4, 5 and 6 use vi command to edit
file name references in machine configuration (VMX) file created in step 4
Syntax: vi %vmx-path%
Example: vi /vmfs/volumes/datastore1/vm01/vm01.vmx
Note: When finished editing, press ESC, type :wq and press Enter
Register restored virtual machine using vim-cmd solo/registervm command and virtual machine
configuration (VMX) file created in step 4
Syntax: vim-cmd solo/registervm %vmx-path%
Example: vim-cmd solo/registervm /vmfs/volumes/datastore1/vm01/vm01.vmx
Obtain restored virtual machine’s VMID using vim-cmd vmsvc/getallvms command, the VMID will
be used to power-on the restored virtual machine in step 10
Syntax: vim-cmd vmsvc/getallvms
Note: The VMID is listed in the first column, make a note of this
Power-on restored virtual machine using vim-cmd vmsvc/power.on command and restored virtual
machine’s VMID obtained in step 9
Syntax: vim-cmd vmsvc/power.on %vmid%
Example: vim-cmd vmsvc/power.on 54

Note 1: Restoring a virtual machine using VMware Shell requires ESXi Shell (for local shell) or SSH (for
remote shell) service to be running on the host server.
Note 2: If the virtual machine backup was previously instantly restored, and is now running or registered
from backup storage, it must first be powered-off and removed inventory before completing these
steps.
Restoring Virtual Machine from Backup ” on page 25 or “Error! Reference source not found.” on page
Error! Bookmark not defined. for instructions).

Restoring Virtual Machine from Backup Using Thinware vBackup Client
Virtual machine backups created by Thinware vBackup can be restored using the Restore Backup wizard
in Thinware vBackup Client. Complete the following steps to restore a virtual machine backup using
Thinware vBackup Client:
1.
2.
3.
4.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the backup is for in the inventory tree on the left
On the virtual machine’s Backups tab, right-click the backup and click “Restore…”
On the Restore Backup Wizard, enter a name for the new virtual machine, select the host server and
datastore to create it on and click Next
5. Review the virtual machine summary and click Next
6. Select appropriate options for the restoration process and click Next
7. Review the wizard summary and click Restore to begin the restoration process
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8. Once the restoration process completes, review the process summary and click Close to close the
Restore Backup wizard
Note: The use of the Restore Backup wizard in Thinware vBackup Client requires the SSH service to be
running on the host server.

Restoring Virtual Machine from Backup Using VMware vCenter Converter
Standalone
Virtual machine backups created by Thinware vBackup are created in native VMware format, meaning
you don’t necessarily need to use Thinware vBackup Client to restore them. If you are more familiar or
more comfortable with using VMware vCenter Converter Standalone, this works just as well as the
Restore Backup wizard in Thinware vBackup Client. Complete the following steps to restore a virtual
machine backup using VMware vCenter Converter Standalone:
1. In VMware vCenter Converter Standalone, from the File menu choose New > “Convert machine…”
2. Select “Backup image or third-party virtual machine” for source type, select the VMX file (example:
D:\Backup\vlab5vm01\130120_040644\vlab5vm01.vmx) in the virtual machine backup’s folder for
Virtual machine file and click Next
3. Select “VMware Infrastructure virtual machine” for destination type, enter connection information
for VMware Infrastructure server and click Next
4. Enter a name for the new virtual machine and click Next
5. Select the datastore, host and virtual machine version and click Next
6. Set parameters for the conversion task as needed and click Next
7. Review the conversion summary and click Finish to begin the restoration process

Recovering Individual Files and Folders from Backup Located on
Local Accessible Backup Repository
Recovering Individual Files and Folders from Backup Using Thinware vBackup
Client
Virtual disks contained in virtual machine backups created by Thinware vBackup can be mounted as a
separate drive in Windows to facilitate recovery of files and folders using the Mount Disks feature in
Thinware vBackup Client. Complete the following steps to mount a virtual machine backup’s virtual disk
and recover individual files and folders using Thinware vBackup Client:
1.
2.
3.
4.
5.
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In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the backup is for in the inventory tree on the left
On the virtual machine’s Backups tab, right-click the backup and choose “Mount Disks…”
On the Mount Disks form, select the disk you wish to mount and click “Mount…”
On the Mount Disk form, enter the volume number you wish to mount, choose the drive letter to be
used and click OK
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6. You will be directed back to the Mount Disks form and the volume and drive letter will be indicated
next to all disks that are currently mounted
7. When done, select the disk you wish to unmount and click Unmount or simply close the Mount Disks
form to unmount all mounted disks

Recovering Individual Files and Folders from Backup Using VMware Disk Mount
Virtual disks contained in virtual machine backups created by Thinware vBackup are compatible with the
VMware Disk Mount utility. VMware Disk Mount is installed with VMware Virtual Disk Development Kit
and allows you to mount a virtual disk as a separate drive in Windows. Complete the following steps to
mount a virtual machine backup’s virtual disk and recover individual files and folders using VMware Disk
Mount:
1.
2.
3.
4.
5.
6.

In Thinware vBackup Client, from the View menu, choose Inventory
Select the virtual machine the backup is for in the inventory tree on the left
On the virtual machine’s Backups tab, right-click the backup and choose Open
Make a note of the virtual disk’s name that you wish to mount (example: vlab5vm01.vmdk)
Open Command Prompt (Windows Start menu > All Programs > Accessories > Command Prompt)
Mount the virtual disk as a drive by executing a command based on the following syntax:
Syntax: vmware-mount %drive-letter%: %vmdk-path% /v:%volume-number% /m:n
Example: "C:\Program Files (x86)\VMware\VMware Virtual Disk Development

Kit\bin\vmware-mount.exe" X: D:\Backup\vlab5vm01\130120_040644\vlab5vm01.vmdk
/v:1 /m:n

7. Open the drive mounted in step 6 and restore individual files and folders as needed
8. When done, remove the mounted drive by executing a command based on the following syntax:
Syntax: vmware-mount %drive-letter%: /d
Example: "C:\Program Files (x86)\VMware\VMware Virtual Disk Development
Kit\bin\vmware-mount.exe" X: /d
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